]> Pileus Git - ~andy/sunrise/blob - media-sound/gogglesmm/gogglesmm-0.12.1.ebuild
036ee1e7013494b3a071aa88b83a55da06da8687
[~andy/sunrise] / media-sound / gogglesmm / gogglesmm-0.12.1.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 DESCRIPTION="Lightweight FOX music collection manager and player"
8 HOMEPAGE="http://gogglesmm.googlecode.com/"
9 SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="dbus gcrypt"
15
16 RDEPEND="dev-db/sqlite:3
17         media-libs/taglib
18         media-libs/xine-lib
19         net-misc/curl
20         x11-libs/fox[png]
21         dbus? ( sys-apps/dbus )
22         gcrypt? ( dev-libs/libgcrypt )"
23 DEPEND="${RDEPEND}"
24
25 src_prepare() {
26         sed -i -e 's:icons/hicolor/48x48/apps:pixmaps:' Makefile || die
27 }
28
29 src_configure() {
30         local extraconf=""
31         if use gcrypt ; then
32                 extraconf="--with-md5=gcrypt"
33         else
34                 extraconf="--with-md5=internal"
35         fi
36
37         econf ${extraconf} $(use_with dbus)
38 }
39
40 src_install() {
41         emake DESTDIR="${D}" install || die
42
43         dodoc AUTHORS README || die
44 }
45
46 pkg_postinst() {
47         elog "For asf or mp4 tag support, build "
48         elog "media-libs/taglib with USE=\"asf mp4\""
49 }