]> Pileus Git - ~andy/sunrise/blob - media-sound/fische/fische-2.0_beta2.ebuild
media-gfx/ktikz: Properly fix qt deps
[~andy/sunrise] / media-sound / fische / fische-2.0_beta2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit versionator flag-o-matic
6
7 MY_P="${PN}-$(replace_version_separator 2 '-')"
8
9 DESCRIPTION="Sound visualisation gadget that works directly with ALSA"
10 HOMEPAGE="http://www.aufroof.org/?expand=marcel&detail=04_projekte"
11 SRC_URI="http://www.aufroof.org/marcel/04_projekte/${MY_P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="mmx sse"
17
18 DEPEND="media-libs/libsdl
19         media-libs/alsa-lib"
20 RDEPEND="${DEPEND}"
21
22 S=${WORKDIR}/${MY_P}
23
24 src_compile() {
25         use sse && append-flags -DSSE
26         use mmx && append-flags -DMMX
27         econf
28         emake || die "emake failed"
29 }
30
31 src_install() {
32         emake DESTDIR="${D}" install || die "emake install failed"
33 }