]> Pileus Git - ~andy/sunrise/blob - media-sound/basicdsp/basicdsp-1.01.ebuild
media-sound/basicdsp: Whitespace
[~andy/sunrise] / media-sound / basicdsp / basicdsp-1.01.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="A program for experimenting with simple audio DSP algorithms"
8 HOMEPAGE="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/basicdsp/"
9 SRC_URI="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${PN}/${P}.tgz
10         doc? ( http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${PN}/BasicDSP_SPRAT.pdf )"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~x86"
15 IUSE="doc"
16
17 DEPEND=">=x11-libs/wxGTK-2.6.3"
18 RDEPEND=${DEPEND}
19
20 src_unpack() {
21         unpack $A
22         cd "${S}"
23
24         epatch "${FILESDIR}"/makefile.patch
25 }
26
27 src_install() {
28         dobin basicdsp || die "dobin failed"
29         doman basicdsp.1 || die "doman failed"
30         dodoc README.txt || die "dodoc failed"
31         if use doc ; then
32                 dodoc "${DISTDIR}"/BasicDSP_SPRAT.pdf || die "dodoc failed"
33         fi
34 }