]> Pileus Git - ~andy/sunrise/blob - media-sound/basicdsp/basicdsp-1.01.ebuild
app-accessibility/julius: Adding ~amd64 keyword
[~andy/sunrise] / media-sound / basicdsp / basicdsp-1.01.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 WX_GTK_VER="2.8"
8
9 inherit eutils toolchain-funcs wxwidgets
10
11 DESCRIPTION="A program for experimenting with simple audio DSP algorithms"
12 HOMEPAGE="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/basicdsp/"
13 SRC_URI="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${PN}/${P}.tgz
14         doc? ( http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${PN}/BasicDSP_SPRAT.pdf )"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~x86"
19 IUSE="doc"
20
21 DEPEND="x11-libs/wxGTK:2.8[X]"
22 RDEPEND=${DEPEND}
23
24 src_prepare() {
25         epatch "${FILESDIR}"/makefile.patch
26         tc-export CXX
27 }
28
29 src_install() {
30         dobin basicdsp || die "dobin failed"
31         doman basicdsp.1 || die "doman failed"
32         dodoc README.txt || die "dodoc failed"
33         if use doc ; then
34                 dodoc "${DISTDIR}"/BasicDSP_SPRAT.pdf || die "dodoc failed"
35         fi
36 }