]> Pileus Git - ~andy/sunrise/blob - media-sound/abcmidi/abcmidi-2009.12.21.ebuild
65b9d20281f0041c3b60472739be326c48bb9e16
[~andy/sunrise] / media-sound / abcmidi / abcmidi-2009.12.21.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils toolchain-funcs
8
9 MY_PV="${PV//./-}"
10 DESCRIPTION="Programs for processing ABC music notation files"
11 HOMEPAGE="http://abc.sourceforge.net/abcMIDI/"
12 SRC_URI="http://ifdo.pugmarks.com/~seymour/runabc/abcMIDI-${MY_PV}.zip"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 S="${WORKDIR}/${PN}"
20
21 src_prepare() {
22         epatch "${FILESDIR}/${P}_gentoo.patch"
23         rm -rf doc/programming/cvs
24 }
25
26 src_compile() {
27         tc-export CC
28         export LNK="${CC}"
29         default
30 }
31
32 src_install() {
33         emake DESTDIR="${D}" install prefix="/usr" docdir="share/doc/${PF}" || die "Unable to install"
34         docinto programming
35         dodoc doc/programming/* *.abc || die "Unable to install documentation"
36 }