]> Pileus Git - ~andy/sunrise/blob - media-radio/grig/grig-0.7.2.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / media-radio / grig / grig-0.7.2.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6 inherit autotools eutils
7
8 DESCRIPTION="A tool for controlling amateur radios"
9 HOMEPAGE="http://groundstation.sourceforge.net/grig/"
10 SRC_URI="mirror://sourceforge/groundstation/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~x86"
15 IUSE="+hardware"
16
17 DEPEND=">=dev-libs/glib-2.6
18         >=x11-libs/gtk+-2.6
19         >=media-libs/hamlib-1.2.5"
20 RDEPEND="${DEPEND}"
21
22 src_unpack() {
23         unpack ${A}
24         cd "${S}"
25         #patch to support old GtkTooltips above gtk+-2.12
26         epatch "${FILESDIR}/${P}-Tooltip.patch"
27         eautoreconf
28 }
29
30 src_compile() {
31         econf $(use_enable hardware )
32         emake || die "emake failed!"
33 }
34
35 src_install() {
36         emake DESTDIR="${D}" install || die "emake install failed"
37         make_desktop_entry ${PN} "GRig" "/usr/share/pixmaps/grig/grig-logo.png" "Application;HamRadio"
38         # make document installation more Gentoo like
39         rm -rf "${D}/usr/share/grig" || die "cleanup docs failed"
40         dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
41 }