]> Pileus Git - ~andy/sunrise/blob - media-radio/gpredict/gpredict-1.1.ebuild
02d9d1bfc53cdee212ef18640e9034663bc65f01
[~andy/sunrise] / media-radio / gpredict / gpredict-1.1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit autotools eutils
6
7 MY_P="${PN}-${PV/_beta/b}"
8
9 DESCRIPTION="A tool for tracking amateur radio satellites"
10 HOMEPAGE="http://gpredict.oz9aec.net"
11 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~x86"
16 IUSE=""
17
18 RDEPEND=">=dev-libs/glib-2.16.0
19         >=x11-libs/gtk+-2.12
20         >=x11-libs/goocanvas-0.9
21         net-misc/curl"
22 DEPEND="${RDEPEND}
23         dev-util/pkgconfig
24         sys-devel/gettext"
25
26 S=${WORKDIR}/${MY_P}
27
28 src_unpack() {
29         unpack ${A}
30         cd "${S}"
31
32         # remove wrong doc location
33         epatch "${FILESDIR}/${PN}-1.0_beta2-doc.patch"
34
35         eautoreconf
36 }
37
38 src_install() {
39         emake DESTDIR="${D}" install || die "emake install failed"
40         make_desktop_entry ${PN} "GPredict" "/usr/share/pixmaps/gpredict/icons/gpredict-icon.png" Science
41         # provide a link to GPL license to allow the program to show it (see
42         # Help->license menu entry)
43         dosym /usr/portage/licenses/GPL-2 /usr/share/${PN}/COPYING || die "dosym died"
44         dodoc AUTHORS ChangeLog NEWS README TODO  || die "dodoc died"
45 }