]> Pileus Git - ~andy/sunrise/blob - media-plugins/gimp-dds/gimp-dds-2.0.9.ebuild
app-arch/paq8l: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / media-plugins / gimp-dds / gimp-dds-2.0.9.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit toolchain-funcs
8
9 DESCRIPTION="DirectDraw Surface (DDS) format plugin for Gimp 2"
10 HOMEPAGE="http://code.google.com/p/gimp-dds/"
11 SRC_URI="http://gimp-dds.googlecode.com/files/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND=">=media-gfx/gimp-2.6"
19 DEPEND="${RDEPEND}
20         virtual/pkgconfig"
21
22 src_prepare() {
23         sed -e 's:CFLAGS=.*\$(:CFLAGS+=\$(:' \
24             -e 's:LDFLAGS=:LDFLAGS+=:' \
25                 -i Makefile.linux || die
26
27         # Fixing incorrect $(LD) usage
28         # http://code.google.com/p/gimp-normalmap/issues/detail?id=1
29         sed -e 's:\t$(LD) :\t$(CC) :' \
30                 -i Makefile.linux || die
31 }
32
33 src_compile() {
34         emake CC="$(tc-getCC)" || die "emake failed"
35 }
36
37 src_install() {
38         exeinto "$(pkg-config --variable=gimplibdir gimp-2.0)/plug-ins"
39         doexe dds || die "Installation failed"
40
41         # No need to install the gimp-dds.odt or the images, as they have the same
42         # content as the gimp-dds.pdf
43         dodoc README TODO doc/gimp-dds.pdf || die
44 }