]> Pileus Git - ~andy/sunrise/blob - media-libs/unicapgtk/unicapgtk-0.9.8.ebuild
app-dicts/words-bin: Adding ~amd64 keyword
[~andy/sunrise] / media-libs / unicapgtk / unicapgtk-0.9.8.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 DESCRIPTION="GTK2 widget for the unicap video capture library"
8 HOMEPAGE="http://unicap-imaging.org/"
9 SRC_URI="http://unicap-imaging.org/downloads/lib${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="debug doc nls"
15
16 RDEPEND="~media-libs/unicap-${PV}
17         x11-libs/gtk+:2
18         x11-libs/libXv
19         nls? ( virtual/libintl )"
20 DEPEND="${RDEPEND}
21         doc? ( dev-util/gtk-doc )"
22
23 S=${WORKDIR}/lib${P}
24
25 src_configure() {
26         econf \
27                 $(use_enable debug debug-unicapgtk) \
28                 $(use_enable doc gtk-doc) \
29                 $(use_enable nls)
30 }
31
32 src_install() {
33         emake DESTDIR="${D}" install || die
34         dodoc AUTHORS ChangeLog NEWS README || die
35 }