]> Pileus Git - ~andy/sunrise/blob - media-libs/unicap/unicap-0.9.8.ebuild
app-dicts/words-bin: Adding ~amd64 keyword
[~andy/sunrise] / media-libs / unicap / unicap-0.9.8.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 DESCRIPTION="The uniform API for image acquisition devices"
8 HOMEPAGE="http://unicap-imaging.org/"
9 SRC_URI="http://unicap-imaging.org/downloads/lib${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="debug doc ieee1394 libv4l nls threads v4l"
15
16 RDEPEND="ieee1394? ( sys-libs/libraw1394 )
17         nls? ( virtual/libintl )
18         v4l? ( libv4l? ( media-libs/libv4l ) )"
19 DEPEND="${RDEPEND}
20         doc? ( dev-util/gtk-doc )"
21
22 S=${WORKDIR}/lib${P}
23
24 src_configure() {
25         local -a myconf
26
27         if use debug ; then
28                 # thing is presently broken (sloppy upstream)
29                 #myconf=( --enable-thing )
30                 myconf+=( --enable-debug-unicap --enable-debug-ucil --enable-debug-thing )
31                 use ieee1394 && myconf+=( --enable-debug-dcam --enable-debug-vid21394 )
32                 use v4l && myconf+=( --enable-debug-v4l2 )
33         fi
34
35         econf "${myconf[@]}" \
36                 $(use_enable doc gtk-doc) \
37                 $(use_enable ieee1394 dcam) \
38                 $(use_enable ieee1394 vid21394) \
39                 $(use_enable libv4l ) \
40                 $(use_enable nls) \
41                 $(use_enable threads unicap-threads) \
42                 $(use_enable v4l v4l2)
43 }
44
45 src_install() {
46         emake DESTDIR="${D}" install || die
47         dodoc AUTHORS ChangeLog NEWS README || die
48 }