]> Pileus Git - ~andy/sunrise/blob - media-libs/unicap/unicap-0.9.3.ebuild
dev-php/awl: New version for the awl library
[~andy/sunrise] / media-libs / unicap / unicap-0.9.3.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 DESCRIPTION="The uniform API for image acquisition devices"
8 HOMEPAGE="http://unicap-imaging.org/"
9 SRC_URI="http://unicap-imaging.org/download/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="alsa debug gtk ieee1394 nls png theora threads v4l v4l2"
15
16 DEPEND="alsa? ( media-libs/alsa-lib )
17         gtk? ( >=x11-libs/gtk+-2.0 )
18         ieee1394? ( >=sys-libs/libraw1394-0.10.0 )
19         theora? ( media-libs/libtheora )"
20 RDEPEND=${DEPEND}
21
22 src_configure() {
23         local myconf
24
25         if use debug ; then
26                 myconf="${myconf} --enable-thing --enable-debug-unicap
27                         --enable-debug-ucil --enable-debug-thing"
28                 use gtk && myconf="${myconf} --enable-debug-unicapgtk"
29                 use ieee1394 && myconf="${myconf} --enable-debug-dcam
30                         --enable-debug-vid21394"
31                 use v4l && myconf="${myconf} --enable-debug-v4l"
32                 use v4l2 && myconf="${myconf} --enable-debug-v4l2"
33         fi
34
35         econf ${myconf} \
36                 $(use_enable alsa ucil-alsa) \
37                 $(use_enable gtk unicapgtk) \
38                 $(use_enable ieee1394 dcam) \
39                 $(use_enable ieee1394 vid21394) \
40                 $(use_enable nls) \
41                 $(use_enable png ucil-png) \
42                 $(use_enable theora ucil-theora) \
43                 $(use_enable threads unicap-threads) \
44                 $(use_enable v4l) \
45                 $(use_enable v4l2) \
46                 --enable-ucil
47 }
48
49 src_install() {
50         emake DESTDIR="${D}" install || die "emake install failed"
51         dodoc AUTHORS ChangeLog NEWS README README.troubleshooting \
52                 || die "dodoc failed"
53 }