]> Pileus Git - ~andy/sunrise/blob - media-libs/libmetalink/libmetalink-0.0.3.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / media-libs / libmetalink / libmetalink-0.0.3.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit base
8
9 DESCRIPTION="Library for handling Metalink files"
10 HOMEPAGE="http://launchpad.net/libmetalink"
11 SRC_URI="http://code.launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE="expat test"
17
18 RDEPEND="expat? ( dev-libs/expat )
19         !expat? ( >=dev-libs/libxml2-2.6.24 )"
20 DEPEND="${RDEPEND}
21         test? ( dev-util/cunit )"
22
23 src_configure() {
24         local xml_args
25         use expat \
26                 && xml_args=--with-libexpat \
27                 || xml_args=--with-libxml2
28
29         econf ${xml_args} --docdir=/usr/share/doc/${PF}
30 }