]> Pileus Git - ~andy/sunrise/blob - media-libs/libinstrudeo/libinstrudeo-0.1.4.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update header
[~andy/sunrise] / media-libs / libinstrudeo / libinstrudeo-0.1.4.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils autotools
6
7 DESCRIPTION="Provides the necessary logic to capture screen recordings and to process them"
8 HOMEPAGE="http://libinstrudeo.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 DEPEND=">=dev-cpp/libxmlpp-2.10.0
17         >=media-libs/freetype-2.1.9
18         >=dev-libs/glib-2.10.0
19         >=dev-cpp/glibmm-2.8.4
20         media-libs/libvorbis
21         =media-libs/libdc1394-1*
22         || ( media-libs/libdca media-libs/libdts )
23         media-libs/libtheora
24         media-libs/ftgl
25         media-video/ffmpeg
26         media-sound/gsm
27         net-misc/curl
28         dev-libs/openssl
29         sys-libs/zlib
30         virtual/glut"
31 RDEPEND="${DEPEND}"
32
33 src_unpack(){
34         unpack ${A}
35         cd "${S}"
36
37         epatch "${FILESDIR}/img_convert_to_sws_scale.patch"
38         eautoreconf
39 }
40
41 src_compile() {
42         CXXFLAGS="${CXXFLAGS} -D__STDC_CONSTANT_MACROS" econf || die "econf failed"
43         emake || die "emake failed"
44 }
45
46 src_install() {
47         emake DESTDIR="${D}" install || die "emake install failed"
48         dodoc AUTHORS ChangeLog NEWS README
49 }