]> Pileus Git - ~andy/sunrise/blob - media-libs/bellagio/bellagio-0.9.1.ebuild
app-dicts/orayta-books: Bump
[~andy/sunrise] / media-libs / bellagio / bellagio-0.9.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 MY_P="libomxil-${P}"
8
9 DESCRIPTION="An Open Source implementation of the OpenMAX Integration Layer"
10 HOMEPAGE="http://omxil.sourceforge.net"
11 SRC_URI="mirror://sourceforge/omxil/${MY_P}.tar.gz"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="alsa doc fbcon ffmpeg jpeg mad vorbis"
17
18 RDEPEND="
19         media-libs/alsa-lib
20         mad? ( media-libs/libmad )
21         vorbis? ( media-libs/libvorbis )
22         ffmpeg? ( virtual/ffmpeg )"
23 DEPEND="${RDEPEND}"
24
25 S="${WORKDIR}/${MY_P}"
26
27 src_configure() {
28         econf \
29                 --docdir=/usr/share/doc/${PF} \
30                 $(use_enable alsa) \
31                 $(use_enable doc) \
32                 $(use_enable fbcon fbvideosink) \
33                 $(use_enable ffmpeg ffmpegcomponents) \
34                 $(use_enable jpeg) \
35                 $(use_enable mad madcomponents) \
36                 $(use_enable vorbis vorbiscomponents)
37 }