]> Pileus Git - ~andy/sunrise/blob - media-libs/bellagio/bellagio-0.9.1.ebuild
4d8c6b9b3380ba9804fdfbfc3e6611b5de452839
[~andy/sunrise] / media-libs / bellagio / bellagio-0.9.1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="An Open Source implementation of the OpenMAX Integration Layer"
6 HOMEPAGE="http://omxil.sourceforge.net"
7 SRC_URI="mirror://sourceforge/omxil/libomxil-${P}.tar.gz"
8
9 LICENSE="LGPL-2.1"
10 SLOT="0"
11 KEYWORDS="~amd64 ~x86"
12
13 IUSE="alsa doc fbcon ffmpeg jpeg mad vorbis"
14
15 RDEPEND="media-libs/alsa-lib
16          mad? ( media-libs/libmad )
17          vorbis? ( media-libs/libvorbis )
18          ffmpeg? ( media-video/ffmpeg )"
19 DEPEND="${RDEPEND}"
20
21 S="${WORKDIR}/libomxil-${P}"
22
23 src_compile() {
24         econf \
25                 --docdir=/usr/share/doc/${PF} \
26                 $(use_enable alsa) \
27                 $(use_enable doc) \
28                 $(use_enable fbcon fbvideosink) \
29                 $(use_enable ffmpeg ffmpegcomponents) \
30                 $(use_enable jpeg) \
31                 $(use_enable mad madcomponents) \
32                 $(use_enable vorbis vorbiscomponents)
33         emake || die "emake failed"
34 }
35
36 src_install() {
37         emake DESTDIR="${D}" install || die "emake install failed"
38         dodoc ChangeLog || die "dodoc failed"
39 }