]> Pileus Git - ~andy/sunrise/blob - media-gfx/xsplash/xsplash-0.8.5.ebuild
media-gfx/ktikz: Properly fix qt deps
[~andy/sunrise] / media-gfx / xsplash / xsplash-0.8.5.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils
8
9 DESCRIPTION="X-based boot splash"
10 HOMEPAGE="https://launchpad.net/xsplash"
11 SRC_URI="http://launchpad.net/xsplash/trunk/${PV}/+download/${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE=""
17
18 RDEPEND="dev-libs/dbus-glib
19         sys-apps/dbus
20         >=x11-libs/gtk+-2.20:2
21         x11-libs/libX11
22         x11-libs/libXcomposite
23         "
24 DEPEND="${RDEPEND}
25         virtual/pkgconfig
26         "
27
28 src_prepare() {
29         epatch "${FILESDIR}"/${P}-deprecated-gtk_widget_realized.patch
30 }
31
32 src_install() {
33         emake DESTDIR="${D}" install || die
34         dodoc AUTHORS ChangeLog NEWS README TODO || die
35 }