]> Pileus Git - ~andy/sunrise/blob - media-gfx/xaralx/xaralx-0.7_p1692-r1.ebuild
media-gfx/xaralx: Fix quoting and don't install LICENSE file
[~andy/sunrise] / media-gfx / xaralx / xaralx-0.7_p1692-r1.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 WANT_AUTOCONF="latest"
6 WANT_AUTOMAKE="latest"
7 inherit eutils wxwidgets autotools gnome2
8
9 MY_P=XaraLXSrc-${PV/_p/r}
10
11 DESCRIPTION="General purpose vector graphics program"
12 HOMEPAGE="http://www.xaraxtreme.org/"
13 SRC_URI="http://downloads.xara.com/opensource/${MY_P}.tar.bz2"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~x86"
18 IUSE=""
19
20 RDEPEND="x11-libs/gtk+
21         >=x11-libs/wxGTK-2.6.3
22         virtual/libintl
23         >=media-libs/libpng-1.2.8
24         >=media-libs/jpeg-6b
25         app-arch/zip
26         dev-lang/perl
27         >=dev-libs/libxml2-2.6.0"
28 DEPEND="${RDEPEND}
29         dev-util/pkgconfig
30         >=sys-devel/gettext-0.14.3"
31
32 S=${WORKDIR}/${MY_P/Src/}
33
34 pkg_setup() {
35         export WX_GTK_VER="2.6"
36         need-wxwidgets unicode
37 }
38
39 src_unpack() {
40         unpack ${A}
41         cd "${S}"
42         sed -i -e "s/CXFTreeDlg:://" Kernel/cxftree.h
43         sed -i -e "s:XaraLX:xaralx:g" Makefile.am
44
45         AT_M4DIR=". ${S}/m4" eautoreconf
46 }
47
48 src_compile() {
49         econf \
50                 --with-wx-config=${WX_CONFIG} \
51                 --with-wx-base-config=${WX_CONFIG} \
52                 --enable-xarlib \
53                 --enable-filters \
54                 || die "econf failed"
55
56         emake || die "emake failed"
57 }
58
59 src_install() {
60         emake DESTDIR="${D}" install || die "emake install failed"
61
62         insinto /usr/share/${PN}
63         doins -r Designs Templates
64
65         doicon ${PN}.png
66         domenu ${PN}.desktop
67
68         insinto /usr/share/icons/hicolor/48x48/mimetypes
69         newins xaralx.png gnome-mime-application-vnd.xara.png
70         insinto /usr/share/mime/packages
71         doins Mime/xaralx.xml
72         insinto /usr/share/application-registry
73         doins Mime/mime-storage/gnome/xaralx.applications
74         insinto /usr/share/mime-info
75         doins Mime/mime-storage/gnome/xaralx.{keys,mime}
76
77         doman doc/xaralx.1
78         dodoc AUTHORS ChangeLog NEWS README \
79                 doc/{gifutil.txt,mtrand.txt,XSVG.txt}
80         newdoc doc/en/LICENSE LICENSE-docs
81         dodir /usr/share/doc/${PF}/html
82         tar xzf doc/en/xaralxHelp.tar.gz -C "${D}"/usr/share/doc/${PF}/html
83 }