]> Pileus Git - ~andy/sunrise/blob - media-gfx/xaralx/xaralx-0.6_pre1479.ebuild
dev-util/mockpp: eautoreconf dies by itself
[~andy/sunrise] / media-gfx / xaralx / xaralx-0.6_pre1479.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils wxwidgets autotools
6
7 MY_P=XaraLX-${PV/_pre/r}
8
9 DESCRIPTION="Xara LX is a commercial vector graphics platform, recently made
10 available on Gentoo as a free OpenSource port."
11 HOMEPAGE="http://www.xaraxtreme.org"
12 SRC_URI="http://downloads2.xara.com/opensource/${MY_P}.tar.bz2"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~x86"
17 IUSE=""
18
19 RDEPEND="x11-libs/gtk+
20         >=x11-libs/wxGTK-2.6.3
21         virtual/libintl
22         >=media-libs/libpng-1.2.8
23         >=media-libs/jpeg-6b
24         app-arch/zip
25         dev-lang/perl
26         >=dev-libs/libxml2-2.6.0"
27 DEPEND="${RDEPEND}
28         dev-util/pkgconfig
29         >=sys-devel/gettext-0.14.3"
30
31 S=${WORKDIR}/${MY_P}
32
33 pkg_setup() {
34         export WX_GTK_VER="2.6"
35         need-wxwidgets unicode
36 }
37
38 src_unpack() {
39         unpack ${A}
40         cd "${S}"
41
42         eautoreconf
43 }
44
45 src_compile() {
46         econf --with-wx-config=${WX_CONFIG} --with-wx-base-config=${WX_CONFIG} \
47                 || die "econf failed"
48
49         emake || die "emake failed"
50 }
51
52 src_install() {
53         # For now installs just the bin
54         emake DESTDIR="${D}" install || die "emake install failed"
55
56         doicon ${PN}.png
57         dodoc README
58
59         # Fix and install desktop file
60         sed -i -e "s#c=xaralx#c=XaraLX#g" ${PN}.desktop
61         domenu ${PN}.desktop
62 }