]> Pileus Git - ~andy/sunrise/blob - media-gfx/tintii/tintii-2.4.0.ebuild
d3e01e971482b6c2adeff95e1f2b1627330dd1f5
[~andy/sunrise] / media-gfx / tintii / tintii-2.4.0.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6 WX_GTK_VER="2.9"
7
8 inherit flag-o-matic scons-utils toolchain-funcs wxwidgets
9
10 DESCRIPTION="Photo filter, striking colour pops in seconds"
11 HOMEPAGE="http://www.indii.org/software/tintii"
12 SRC_URI="mirror://sourceforge/tint/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE="doc"
18
19 RDEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X]"
20 DEPEND="${RDEPEND}
21         dev-libs/boost
22         doc? ( app-doc/doxygen )"
23
24 pkg_setup() {
25         append-cxxflags `wx-config --cxxflags`
26         append-ldflags "-fopenmp" $(no-as-needed)
27         LINKFLAGS="${LDFLAGS} `wx-config --libs` `wx-config --libs aui`"
28 }
29
30 src_compile() {
31         escons || die
32
33         if use doc ; then
34                 doxygen Doxyfile || die
35         fi;
36 }
37
38 src_install() {
39         dobin ${PN} || die
40         dodoc README.txt || die
41
42         if use doc ; then
43                 dohtml srcdocs/html/* || die
44         fi;
45 }