]> Pileus Git - ~andy/sunrise/blob - media-gfx/printoxx/printoxx-2.0.1.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / media-gfx / printoxx / printoxx-2.0.1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 #FIXME: This package doesn't need install userguide html docs implicitly
8 # (for example i don't want them)
9 DESCRIPTION="Program for printing one or more image files with a user-defined page layout"
10 HOMEPAGE="http://kornelix.squarespace.com/printoxx"
11 SRC_URI="http://kornelix.squarespace.com/storage/downloads/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND=">=x11-libs/gtk+-2.8"
19 RDEPEND="${DEPEND}"
20
21 src_compile() {
22         emake || die "build failed"
23 }
24
25 src_install() {
26         emake DESTDIR="${D}" PREFIX=/usr install || die "emake install failed"
27         make_desktop_entry ${PN} "Printoxx" /usr/share/${PN}/icons/${PN}.png "Application;Graphics;2DGraphics;"
28         rm "${D}"/usr/share/doc/${PN}/{COPYING,README} || die "Clean-up unnecessary docs failed"
29 }