]> Pileus Git - ~andy/sunrise/blob - media-gfx/pinta/pinta-9999.ebuild
net-print/gnome-manual-duplex: version bump
[~andy/sunrise] / media-gfx / pinta / pinta-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit autotools fdo-mime git-2 multilib mono
8
9 DESCRIPTION="Simple Painting for Gtk"
10 HOMEPAGE="http://pinta-project.com"
11 SRC_URI=""
12
13 EGIT_REPO_URI="git://github.com/PintaProject/Pinta.git"
14
15 LICENSE="MIT CCPL-Attribution-3.0"
16 SLOT="0"
17 KEYWORDS=""
18 IUSE=""
19
20 RDEPEND="dev-dotnet/gtk-sharp:2
21         dev-dotnet/mono-addins[gtk]
22         dev-lang/mono
23         x11-libs/cairo"
24 DEPEND="${RDEPEND}
25         dev-util/intltool
26         dev-util/pkgconfig
27         sys-devel/gettext"
28
29 src_prepare() {
30         sed -e "s/lib/$(get_libdir)/" -i pinta.in || die
31         eautoreconf
32         intltoolize --copy --automake --force || die "intltoolize failed"
33 }
34
35 pkg_postinst() {
36         fdo-mime_desktop_database_update
37         fdo-mime_mime_database_update
38 }
39
40 pkg_postrm() {
41         fdo-mime_desktop_database_update
42         fdo-mime_mime_database_update
43 }