]> Pileus Git - ~andy/sunrise/blob - media-gfx/pho/pho-0.9.6.ebuild
games-board/qbriscola: Fix qt deps, EAPI bump, add ~amd64 keyword
[~andy/sunrise] / media-gfx / pho / pho-0.9.6.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit toolchain-funcs
8
9 DESCRIPTION="GTK image viewer"
10 HOMEPAGE="http://shallowsky.com/software/pho/"
11 SRC_URI="http://shallowsky.com/software/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc"
16 IUSE=""
17
18 RDEPEND="x11-libs/gtk+:2"
19 DEPEND="${RDEPEND}
20         virtual/pkgconfig"
21
22 src_prepare() {
23         sed -i -e "s:-g -O -Wall:${CFLAGS}:" Makefile\
24                 || die "sed fix of cflags failed"
25         sed -i -e "s:-Wall -g -O2:${CFLAGS}:" exif/Makefile\
26                 || die "sed fix of cflags2 failed"
27         tc-export CC
28 }
29
30 src_install() {
31         dobin pho || die "installation failed"
32         doman pho.1
33 }