]> Pileus Git - ~andy/sunrise/blob - media-gfx/pho/pho-0.9.5.1.ebuild
media-gfx/argyllcms: New application, see bug 125774. Thanks go to Guillaume Castagni...
[~andy/sunrise] / media-gfx / pho / pho-0.9.5.1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="GTK image viewer"
6 HOMEPAGE="http://shallowsky.com/software/pho/"
7 SRC_URI="http://shallowsky.com/software/${PN}/${P}.tar.gz"
8
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS="~amd64 ~ppc"
12 IUSE=""
13
14 DEPEND="dev-util/pkgconfig
15         x11-libs/gtk+"
16 RDEPEND="x11-libs/gtk+"
17
18 src_unpack() {
19         unpack ${A}
20         cd "${S}"
21         sed -i -e "s:-g -O -Wall:${CFLAGS}:" Makefile\
22                 || die "sed fix of cflags failed"
23         sed -i -e "s:-Wall -g -O2:${CFLAGS}:" exif/Makefile\
24                 || die "sed fix of cflags2 failed"
25 }
26
27 src_install() {
28         dobin pho || die "installation failed"
29         doman pho.1
30 }