]> Pileus Git - ~andy/sunrise/blob - media-gfx/mypaint/mypaint-0.7.1.ebuild
media-gfx/gimp-lqr-plugin: gimp-lqr-plugin move to gx86.
[~andy/sunrise] / media-gfx / mypaint / mypaint-0.7.1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="fast and easy graphics application for digital painters"
8 HOMEPAGE="http://mypaint.intilinux.com/"
9 SRC_URI="http://download.gna.org/${PN}/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 RDEPEND="dev-python/pygtk
17         dev-python/numpy
18         >=dev-python/pycairo-1.4
19         >=dev-lang/python-2.4
20         <dev-lang/python-3"
21 DEPEND="${RDEPEND}
22         >=dev-util/scons-1.0
23         dev-lang/swig"
24
25 src_compile() {
26         scons || die "scons failed"
27 }
28
29 src_install () {
30         scons prefix="${D}/usr" install || die "scons install failed"
31         doicon desktop/mypaint_48.png
32 }