]> Pileus Git - ~andy/sunrise/blob - media-gfx/mashup/mashup-2.9.ebuild
sci-visualization/tulip: Fix qt deps
[~andy/sunrise] / media-gfx / mashup / mashup-2.9.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils toolchain-funcs
8
9 DESCRIPTION="Program for printing one or more image files with a user-defined page layout"
10 HOMEPAGE="http://kornelix.squarespace.com/mashup"
11 SRC_URI="http://kornelix.squarespace.com/storage/downloads/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND="x11-libs/gtk+:2"
19 RDEPEND="${DEPEND}"
20
21 src_prepare() {
22         epatch "${FILESDIR}"/${P}-ldflags.patch
23 }
24
25 src_compile() {
26         # provide real PREFIX here as it is used in zfuncs.cc
27         # provide HTML-dir for DOCDIR as it used only to display the userguide
28         emake CXX="$(tc-getCXX)" PREFIX=/usr DOCDIR=/usr/share/doc/${PF}/html || die
29 }
30
31 src_install() {
32         dobin ${PN}
33         insinto /usr/share/${PN}
34         doins data/*
35         doicon icons/*
36         insinto /usr/share/
37         doins -r locales/*
38
39         make_desktop_entry ${PN} "Printoxx" /usr/share/${PN}/icons/${PN}.png "Application;Graphics;2DGraphics;"
40         newman doc/${PN}.man ${PN}.1 || die
41
42         rm -rf "${D}"/tmp || die
43         dodoc doc/{CHANGES,TRANSLATIONS} || die
44         dohtml -r doc/*.html doc/images || die
45 }