]> Pileus Git - ~andy/sunrise/blob - media-gfx/mapivi/mapivi-0.9.1.ebuild
3cd15b69f1342c6400738f6629b37d0962df7448
[~andy/sunrise] / media-gfx / mapivi / mapivi-0.9.1.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 MY_P="${PN}091"
6 DESCRIPTION="picture manager / organizer written in Perl/Tk"
7 HOMEPAGE="http://mapivi.sourceforge.net/mapivi.shtml"
8 SRC_URI="mirror://sourceforge/mapivi/${MY_P}.tgz"
9
10 IUSE=""
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14
15 DEPEND="dev-lang/perl
16         >=dev-perl/perl-tk-804.025
17         dev-perl/ImageInfo
18         media-gfx/jhead
19         media-gfx/imagemagick
20         media-libs/jpeg
21         dev-perl/Image-MetaData-JPEG"
22
23 S="${WORKDIR}/${MY_P}"
24
25 src_unpack() {
26         unpack ${A}
27         cd "${S}"
28         sed -i -e 's:$configdir/PlugIns:/usr/share/mapivi/plugins:' mapivi
29 }
30
31 src_install() {
32         dobin mapivi
33
34         exeinto /usr/share/mapivi/plugins
35         doexe PlugIns/{Channel-Separator,Join-RGB,checkDir-plugin,filelist-plugin,test-plugin}
36         dodoc Changes.txt FAQ README Tips.txt ToDo
37 }
38
39 pkg_postinst() {
40         ewarn "If your Gimp version is 2.3 from CVS you should run:"
41         ewarn "sed -i 's:gimp-remote -n  :gimp-remote:g' /usr/bin/mapivi"
42         ewarn "sed -i '22732,22734s:^.:\#:g' /usr/bin/mapivi"
43         ewarn "sed -i '22735s:\#execute:execute:g' /usr/bin/mapivi"
44         ewarn "after instalation to have edit in Gimp option work."
45 }