]> Pileus Git - ~andy/sunrise/blob - media-gfx/gimp-cmyk-plugin/gimp-cmyk-plugin-0.5.4.ebuild
dev-python/eventlet: New version and test additions. Thanks to Tommy[D]
[~andy/sunrise] / media-gfx / gimp-cmyk-plugin / gimp-cmyk-plugin-0.5.4.ebuild
1 # Copyright 2007-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit base toolchain-funcs
6
7 MY_P="separate+-${PV}"
8
9 DESCRIPTION="Gimp CMYK plug-in."
10 HOMEPAGE="http://cue.yellowmagic.info/softwares/separate.html"
11 SRC_URI="mirror://sourceforge.jp/separate-plus/41810/${MY_P}.zip
12          http://download.adobe.com/pub/adobe/iccprofiles/win/AdobeICCProfilesCS4Win_end-user.zip"
13
14 LICENSE="GPL-2 Adobe"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 RDEPEND="media-libs/lcms
20         media-libs/tiff
21         media-gfx/gimp"
22 DEPEND="${RDEPEND}"
23
24 S="${WORKDIR}/${MY_P}"
25
26 PATCHES=(
27         "${FILESDIR}"/${PV}-Makefile.patch
28         )
29
30 src_compile() {
31         emake \
32                 CC="$(tc-getCC)" \
33                 || die "compilation failed"
34 }
35
36 src_install() {
37         emake PREFIX="${D}/usr" install || die "emake install failed"
38         insinto /usr/share/color/icc
39         doins -r sRGB || die "doins failed installing sRGB icc profiles"
40         cd "${WORKDIR}/Adobe ICC Profiles (end-user)"
41         doins -r CMYK RGB || die "doins failed installing Adobe CMYK and RGB icc profiles"
42 }