]> Pileus Git - ~andy/sunrise/blob - media-gfx/fyre/fyre-1.0.1.ebuild
sci-geosciences/aweather: Bump to 0.8, update homepage, and test on amd64
[~andy/sunrise] / media-gfx / fyre / fyre-1.0.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 GCONF_DEBUG="no"
8 SCROLLKEEPER_UPDATE="0"
9
10 inherit gnome2 eutils
11
12 DESCRIPTION="Fyre renders and animates Peter de Jong maps"
13 HOMEPAGE="http://fyre.navi.cx/"
14 SRC_URI="http://releases.navi.cx/${PN}/${P}.tar.bz2"
15
16 SLOT="0"
17 LICENSE="GPL-2"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="gnet openexr"
20
21 RDEPEND="dev-libs/glib:2
22         gnome-base/libglade
23         x11-libs/gtk+:2
24         gnet? ( net-libs/gnet )
25         openexr? ( media-libs/openexr )"
26 DEPEND="${RDEPEND}
27         dev-util/desktop-file-utils
28         virtual/pkgconfig
29         x11-misc/shared-mime-info"
30
31 pkg_setup() {
32         G2CONF="$(use_enable gnet) $(use_enable openexr)"
33 }
34
35 src_prepare() {
36         epatch "${FILESDIR}"/${PN}_file_dialog_pause_fix.patch
37 }
38
39 src_install() {
40         #...=/bin/true prevents the makefile from updating mime and .desktop
41         # databases on its own
42         emake DESTDIR="${D}" \
43                 update_xdgmime=/bin/true update_fdodesktop=/bin/true \
44                 install || die
45         dodoc AUTHORS ChangeLog README TODO || die
46
47         if use gnet; then
48                 newconfd "${FILESDIR}/${P}-conf" ${PN} || die
49                 newinitd "${FILESDIR}/${P}-init" ${PN} || die
50         fi
51 }