]> Pileus Git - ~andy/sunrise/blob - media-gfx/fotoxx/fotoxx-6.4.2.ebuild
media-gfx/rawtherapee: Remove removed accessibility usedep of gtkmm, fixes bug 265374
[~andy/sunrise] / media-gfx / fotoxx / fotoxx-6.4.2.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="Program for improving image files made with a digital camera."
8 HOMEPAGE="http://kornelix.squarespace.com/fotoxx"
9 SRC_URI="http://kornelix.squarespace.com/storage/downloads/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND=">=x11-libs/gtk+-2.8
17         media-libs/freeimage"
18 RDEPEND="${DEPEND}
19         media-libs/exiftool
20         media-gfx/ufraw
21         x11-misc/xdg-utils
22         media-gfx/printoxx"
23
24 src_compile() {
25         emake PREFIX=/usr || die "build failed"
26 }
27
28 src_install() {
29         emake DESTDIR="${D}" PREFIX=/usr install || die "emake install failed"
30         make_desktop_entry ${PN} "Fotoxx" /usr/share/${PN}/icons/${PN}.png "Application;Graphics;2DGraphics;"
31 }