]> Pileus Git - ~andy/sunrise/blob - media-gfx/fotoxx/fotoxx-5.9.ebuild
net-p2p/freenet: New upstream release
[~andy/sunrise] / media-gfx / fotoxx / fotoxx-5.9.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="Program for improving image files made with a digital camera."
8 HOMEPAGE="http://kornelix.squarespace.com/fotoxx"
9 SRC_URI="http://kornelix.squarespace.com/storage/downloads/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND=">=x11-libs/gtk+-2.8"
17 RDEPEND="${DEPEND}
18         media-gfx/exiv2
19         >=media-gfx/printoxx-1.2"
20
21 S=${WORKDIR}/${PN}
22
23 src_compile() {
24         emake PREFIX=/usr || die "build failed"
25 }
26
27 src_install() {
28         emake DESTDIR="${D}" PREFIX=/usr install || die "emake install failed"
29         make_desktop_entry ${PN} "Fotoxx" /usr/share/${PN}/icons/${PN}.png "Application;Graphics;2DGraphics;"
30 }