]> Pileus Git - ~andy/sunrise/blob - media-gfx/fontmatrix/fontmatrix-0.6.0.ebuild
0e5fc6a6c35339d89f80c9f0fe011db3b2b5b1ef
[~andy/sunrise] / media-gfx / fontmatrix / fontmatrix-0.6.0.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit qt4 cmake-utils
8
9 DESCRIPTION="A font manager"
10 HOMEPAGE="http://www.fontmatrix.net/"
11 SRC_URI="http://www.fontmatrix.net/archives/${P}-Source.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="debug"
17
18 RDEPEND="x11-libs/qt-gui:4
19         x11-libs/qt-svg:4
20         x11-libs/qt-webkit:4
21         media-libs/freetype:2"
22 DEPEND=${RPEDEND}
23
24 S=${WORKDIR}/${P}-Source
25
26 src_configure() {
27         local mycmakeargs="-DOWN_SHAPER=1"
28         cmake-utils_src_configure
29 }
30
31 src_install() {
32         dobin "${CMAKE_BUILD_DIR}"/src/${PN} || die
33         doman ${PN}.1 || die
34         domenu ${PN}.desktop || die
35         dodoc ChangeLog TODO || die
36 }
37
38 pkg_postinst() {
39         elog "If you encounter problems or just have questions or if you have"
40         elog " suggestions, please take time to suscribe to the undertype-users"
41         elog " mailing list ( https://mail.gna.org/listinfo/undertype-users )."
42         elog " If you want to reach us quickly, come to #fontmatrix at Freenode."
43 }