]> Pileus Git - ~andy/sunrise/blob - media-gfx/f4l/f4l-0.2.1.ebuild
sunrise/app-portage/elog-list/elog-list-0.0.6.ebuild: change headers to make repoman...
[~andy/sunrise] / media-gfx / f4l / f4l-0.2.1.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit qt3 eutils
6
7 DESCRIPTION="F4L is an open source development environment for Macromedia Flash"
8 HOMEPAGE="http://f4l.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 DEPEND="=x11-libs/qt-3*"
17 RDEPEND="${DEPEND}"
18
19 src_unpack() {
20         unpack ${A}
21         cd "${S}"
22
23         # Fix gcc4.1 compatibility
24         epatch "${FILESDIR}/${P}-gcc41.patch"
25 }
26
27 src_compile() {
28         eqmake3 ${PN}.pro -o Makefile
29         emake || die "emake failed"
30 }
31
32 src_install() {
33         dobin bin/${PN}
34         newicon src/cursor/main_ico1.xpm ${PN}.xpm
35         make_desktop_entry ${PN} "Flash for Linux" ${PN}.xpm Graphics
36 }