]> Pileus Git - ~andy/sunrise/blob - media-gfx/exact-image/exact-image-0.7.4.ebuild
media-gfx/exact-image: Version bump, remove old
[~andy/sunrise] / media-gfx / exact-image / exact-image-0.7.4.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 DESCRIPTION="A fast, modern and generic image processing library"
8 HOMEPAGE="http://www.exactcode.de/site/open_source/exactimage/"
9 SRC_URI="http://dl.exactcode.de/oss/${PN}/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="agg expat jpeg jpeg2k lcms lua openexr php perl python ruby swig tiff truetype X"
15
16 RDEPEND="agg? ( x11-libs/agg[truetype] )
17         expat? ( dev-libs/expat )
18         jpeg2k? ( media-libs/jasper )
19         jpeg? ( media-libs/jpeg )
20         lcms? ( media-libs/lcms )
21         lua? ( dev-lang/lua )
22         openexr? ( media-libs/openexr )
23         php? ( dev-lang/php )
24         perl? ( sys-devel/libperl )
25         python? ( dev-lang/python )
26         ruby? ( dev-lang/ruby )
27         tiff? ( media-libs/tiff )
28         truetype? ( >=media-libs/freetype-2 )
29         X? (
30                 x11-libs/libXext
31                 x11-libs/libXt
32                 x11-libs/libICE
33                 x11-libs/libSM
34         )"
35
36 DEPEND="${RDEPEND}
37         swig? ( dev-lang/swig )"
38
39 src_configure() {
40         # evas support is disabled since evas is not on main tree. You can find it
41         # on enlightenment overlay
42         # bardecode is disabled since it is protected by custom licence
43         # libungif is disabled as it is not supported anymore
44         myconf=" --without-libungif --without-evas \
45                 --without-bardecode --prefix=/usr
46                 $(use_with jpeg libjpeg)\
47                 $(use_with lua) \
48                 $(use_with php) \
49                 $(use_with ruby) \
50                 $(use_with python) \
51                 $(use_with swig) \
52                 $(use_with agg libagg) \
53                 $(use_with lcms) \
54                 $(use_with tiff libtiff) \
55                 $(use_with truetype freetype) \
56                 $(use_with expat) \
57                 $(use_with openexr) \
58                 $(use_with jpeg2k jasper) \
59                 $(use_with X x11)"
60         #econf fails
61         ./configure ${myconf} || die "configure failed"
62 }
63
64 src_install() {
65         emake DESTDIR="${D}" install || die "emake install failed"
66         dodoc README || die "dodoc failed"
67 }