]> Pileus Git - ~andy/sunrise/blob - media-gfx/denormgen/denormgen-1.5.ebuild
dev-db/cppdb: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / media-gfx / denormgen / denormgen-1.5.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit autotools
6
7 DESCRIPTION="creates normal/height maps from high resolution meshes for games or 3d applications"
8 HOMEPAGE="http://epsylon.rptd.ch/denormgen.php"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 DEPEND=">=x11-libs/fox-1.2"
17 RDEPEND="${DEPEND}"
18
19 src_unpack(){
20         unpack ${A}
21         cd "${S}"
22         eautoreconf
23 }
24
25 src_install(){
26         emake DESTDIR="${D}" install || die "emake install failed"
27
28         # http://bugs.gentoo.org/show_bug.cgi?id=134456#c7
29         #
30         # the blender build does not yet have a fixed place
31         # where scripts go into. the 2.41 version uses
32         # /usr/lib/blender/scripts but the next version already uses
33         # /usr/share/blender/scripts/ . once this directory
34         # is fixed the following line has to be changed
35         # to copy the script into the right place instead
36         # of the current placeholder directory.
37         insinto /usr/share/${P}/scripts
38         doins scripts/dragengine_dim_export.py
39
40         dodoc AUTHORS ChangeLog README TODO
41 }
42
43 pkg_postinst(){
44         elog "The .dim file format changed with this version."
45         elog "Old .dim files are no more compatible with this release."
46 }