]> Pileus Git - ~andy/sunrise/blob - media-gfx/context-free/context-free-2.2_beta2.ebuild
media-gfx/ktikz: Properly fix qt deps
[~andy/sunrise] / media-gfx / context-free / context-free-2.2_beta2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils versionator
6
7 MY_PV=$(replace_version_separator 2 '')
8
9 DESCRIPTION="A program that generates images from instructions written in context-free grammar"
10 HOMEPAGE="http://www.contextfreeart.org/"
11 SRC_URI="http://www.contextfreeart.org/download/ContextFreeSource${MY_PV}.tgz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE=""
17
18 DEPEND="media-libs/libpng"
19 RDEPEND=${DEPEND}
20
21 S=${WORKDIR}/ContextFreeSource${MY_PV}
22
23 src_unpack() {
24         unpack ${A}
25         epatch "${FILESDIR}/${P}-fix-cpp-headers.patch"
26 }
27
28 src_install() {
29         dobin cfdg || die
30 }
31
32 src_test() {
33         make rtests OUTPUT_DIR="${T}" || die "tests failed"
34 }