]> Pileus Git - ~andy/sunrise/blob - media-gfx/argyllcms/argyllcms-1.1.1.ebuild
media-gfx/gimp-lqr-plugin: Version Bump
[~andy/sunrise] / media-gfx / argyllcms / argyllcms-1.1.1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 MY_P="Argyll_V${PV}"
6 DESCRIPTION="Open source, ICC compatible color management system"
7 HOMEPAGE="http://www.argyllcms.com/"
8 SRC_URI="http://www.argyllcms.com/${MY_P}_src.zip"
9
10 LICENSE="AGPL-3"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="doc"
14
15 RDEPEND="media-libs/tiff
16         media-libs/jpeg
17         sys-libs/zlib"
18 DEPEND="${RDEPEND}
19         app-arch/unzip
20         dev-util/ftjam"
21
22 S="${WORKDIR}/${MY_P}"
23
24 src_install() {
25         emake install || die
26
27         rm bin/License.txt || die
28         dobin bin/* || die
29
30         if use doc; then
31                 dohtml doc/* || die
32         fi
33
34         dodoc log.txt Readme.txt ttbd.txt notes.txt || die
35
36         insinto /usr/share/${PN}/ref
37         doins   ref/*  || die
38 }
39
40 pkg_postinst() {
41         elog
42         elog "If you have a Spyder2 you need to extract the firmware"
43         elog "from the spyder2_setup.exe (ColorVision CD)"
44         elog "and store it as /usr/bin/spyd2PLD.bin"
45         elog
46         elog "For further info on setting up instrument access read"
47         elog "http://www.argyllcms.com/doc/Installing_Linux.html"
48         elog
49 }