]> Pileus Git - ~andy/sunrise/blob - mail-filter/libdkim-exim/libdkim-exim-1.0.17.ebuild
mail-filter/libdkim-exim: New ebuild for bug 205813 thanks to idl0r
[~andy/sunrise] / mail-filter / libdkim-exim / libdkim-exim-1.0.17.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 MY_P="${P/-exim/}-tk"
8 DESCRIPTION="a library for exim to verify and create signatures of e-mail headers"
9 HOMEPAGE="http://wiki.exim.org/DKIM"
10 SRC_URI="http://duncanthrax.net/exim-experimental/${MY_P}.tar.gz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND="dev-libs/openssl"
18 RDEPEND="${DEPEND}"
19
20 S=${WORKDIR}/${MY_P}/src
21
22 src_unpack() {
23         unpack ${A}
24         cd "${S}"
25
26         # upstream makefile is not very useful.
27         epatch "${FILESDIR}/${MY_P}-Makefile.patch" \
28                "${FILESDIR}/${MY_P}-missing-includes.patch"
29 }
30
31 src_install() {
32         emake DESTDIR="${D}" install || die "emake failed"
33         dodoc ../README || die "Install README failed"
34 }