]> Pileus Git - ~andy/sunrise/blob - mail-filter/gross/gross-1.0.2.ebuild
dev-libs/qextserialport: Fix qt deps, EAPI bump
[~andy/sunrise] / mail-filter / gross / gross-1.0.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils
8
9 DESCRIPTION="gross - Greylisting of suspicious sources"
10 HOMEPAGE="http://code.google.com/p/gross/"
11 SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
12
13 LICENSE="as-is"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="ares milter"
17
18 DEPEND="ares?   ( net-dns/c-ares )
19         milter? ( || ( mail-filter/libmilter mail-mta/sendmail ) )"
20 RDEPEND="${DEPEND}"
21
22 src_prepare() {
23         epatch "${FILESDIR}"/${PN}-fix-paths-and-rm-getline.patch
24 }
25
26 src_configure() {
27         econf \
28                 --sysconfdir=/etc/mail/gross \
29                 $(use_enable milter) \
30                 $(use_enable ares dnsbl)
31 }
32
33 src_install() {
34         emake DESTDIR="${D}" install || die "emake failed"
35         diropts -o nobody -g nobody
36         dodir /var/run/grossd || die "dodir failed"
37         keepdir /var/db/grossd || die "dodir db failed"
38         dodoc ChangeLog NEWS README doc/examples/* || die "dodoc failed"
39         newinitd "${FILESDIR}"/grossd.initd grossd || die "newinitd failed"
40         newconfd "${FILESDIR}"/grossd.confd grossd || die "newconfd failed"
41 }