]> Pileus Git - ~andy/sunrise/blob - kde-misc/kio-sysinfo/kio-sysinfo-1.8.2.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update header
[~andy/sunrise] / kde-misc / kio-sysinfo / kio-sysinfo-1.8.2.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit kde eutils
6
7 DESCRIPTION="kioslave to display system information in konqueror (pardus port)"
8 HOMEPAGE="http://www.kde-apps.org/content/show.php?content=58704"
9 SRC_URI="http://download.tuxfamily.org/kiosysinfo/Sources/${P}.tar.gz
10         branding? ( http://users.electrostorm.net/~krf/files/static/${PN}-background_gentoo.png )"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="branding"
16
17 DEPEND=">=sys-apps/hwinfo-13.28"
18 RDEPEND="${DEPEND}"
19
20 need-kde 3.2
21
22 src_unpack() {
23         unpack ${A}
24         cd "${S}"
25
26         if use branding ; then
27                 cp "${DISTDIR}"/${PN}-background_gentoo.png "${S}"/about/images/background.png
28         fi
29
30         # update some ugly translations
31         epatch "${FILESDIR}"/kio-sysinfo-${PV}-de-translation.patch
32 }