]> Pileus Git - ~andy/gtk/blob - gtk+.spec
1d378e6cac2af9ee13a4ea191b7c3f94690093e3
[~andy/gtk] / gtk+.spec
1 # Note that this is NOT a relocatable package
2 %define ver      0.99.7
3 %define rel      SNAP
4 %define prefix   /usr
5
6 Summary: The Gimp Toolkit
7 Name: gtk+
8 Version: %ver
9 Release: %rel
10 Copyright: LGPL
11 Group: X11/Libraries
12 Source: ftp://ftp.gimp.org/pub/gtk/v0.99/gtk+-%{ver}.tar.gz
13 BuildRoot: /tmp/gtk-root
14 Obsoletes: gtk
15 Packager: Marc Ewing <marc@redhat.com>
16 URL: http://www.gimp.org/gtk
17 Prereq: /sbin/install-info
18 Docdir: %{prefix}/doc
19
20 %description
21 The X libraries originally written for the GIMP, which are now used by
22 several other programs as well.
23
24 %package devel
25 Summary: GIMP Toolkit and GIMP Drawing Kit
26 Group: X11/Libraries
27 Requires: gtk+
28 Obsoletes: gtk-devel
29 PreReq: /sbin/install-info
30
31 %description devel
32 Static libraries and header files for the GIMP's X libraries, which are
33 available as public libraries.  GLIB includes generally useful data
34 structures, GDK is a drawing toolkit which provides a thin layer over
35 Xlib to help automate things like dealing with different color depths,
36 and GTK is a widget set for creating user interfaces.
37
38 %changelog
39
40 * Sun Mar 15 1998 Marc Ewing <marc@redhat.com>
41
42 - Added aclocal and bin stuff to file list.
43
44 - Added -k to the SMP make line.
45
46 - Added lib/glib to file list.
47
48 * Fri Mar 14 1998 Shawn T. Amundson <amundson@gimp.org>
49
50 - Changed version to 0.99.7
51
52 * Fri Mar 14 1998 Shawn T. Amundson <amundson@gimp.org>
53
54 - Updated ftp url and changed version to 0.99.6
55
56 * Thu Mar 12 1998 Marc Ewing <marc@redhat.com>
57
58 - Reworked to integrate into gtk+ source tree
59
60 - Truncated ChangeLog.  Previous Authors:
61   Trond Eivind Glomsrod <teg@pvv.ntnu.no>
62   Michael K. Johnson <johnsonm@redhat.com>
63   Otto Hammersmith <otto@redhat.com>
64   
65 %prep
66 %setup
67
68 %build
69 # Needed for snapshot releases.
70 if [ ! -f configure ]; then
71   CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%prefix
72 else
73   CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%prefix
74 fi
75
76 if [ "$SMP" != "" ]; then
77   (make "MAKE=make -k -j $SMP"; exit 0)
78   make
79 else
80   make
81 fi
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 make prefix=$RPM_BUILD_ROOT%{prefix} install
87
88 gzip -9n $RPM_BUILD_ROOT%{prefix}/info/*
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post -p /sbin/ldconfig
94
95 %postun -p /sbin/ldconfig
96
97 %post devel
98 /sbin/install-info %{prefix}/info/gdk.info.gz %{prefix}/info/dir
99 /sbin/install-info %{prefix}/info/gtk.info.gz %{prefix}/info/dir
100
101 %postun devel
102 if [ $1 = 0 ]; then
103     /sbin/install-info --delete %{prefix}/info/gdk.info.gz %{prefix}/info/dir
104     /sbin/install-info --delete %{prefix}/info/gtk.info.gz %{prefix}/info/dir
105 fi
106
107 %files
108 %defattr(-, root, root)
109
110 %doc AUTHORS COPYING ChangeLog NEWS README TODO
111 %{prefix}/lib/lib*.so.*
112
113 %files devel
114 %defattr(-, root, root)
115
116 %{prefix}/lib/lib*.so
117 %{prefix}/lib/*a
118 %{prefix}/lib/glib
119 %{prefix}/include/*
120 %{prefix}/info/*
121 %{prefix}/share/aclocal/*
122 %{prefix}/bin/*