]> Pileus Git - ~andy/sunrise/blob - gnome-extra/timer-applet/timer-applet-2.0.1.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update header
[~andy/sunrise] / gnome-extra / timer-applet / timer-applet-2.0.1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6
7 inherit gnome2 python multilib
8
9 DESCRIPTION="A countdown timer applet for the GNOME panel"
10 HOMEPAGE="http://timerapplet.sourceforge.net"
11 SRC_URI="mirror://sourceforge/timerapplet/${P}.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="doc sounds libnotify"
16
17 DEPEND="|| ( ( virtual/python:2.4 dev-python/elementtree )
18                 virtual/python:2.5 )
19         >=dev-python/pygtk-2.10
20         >=dev-python/gnome-python-2.16
21         >=dev-python/gnome-python-desktop-2.16
22         >=dev-python/notify-python-0.1
23         >=dev-python/dbus-python-0.8"
24 RDEPEND="${DEPEND}"
25
26 DOCS="AUTHORS Changelog NEWS README"
27
28 src_unpack() {
29         gnome2_src_unpack
30         ln -sf $(type -P true) "${S}/py-compile"
31 }
32
33 pkg_postinst() {
34         python_version
35         python_mod_optimize "/usr/$(get_libdir)/python${PYVER}/site-packages/timerapplet"
36 }
37
38 pkg_postrm() {
39         python_version
40         python_mod_cleanup "/usr/$(get_libdir)/python${PYVER}/site-packages/timerapplet"
41 }