]> Pileus Git - ~andy/sunrise/blob - gnome-extra/teatime/teatime-2.8.0.ebuild
app-misc/japanese-vocabulary: Adding ~amd64 keyword, fixing qt deps properly
[~andy/sunrise] / gnome-extra / teatime / teatime-2.8.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit gnome2 eutils
8
9 DESCRIPTION="A GNOME panel applet that reminds you when your tea is ready"
10 HOMEPAGE="http://det.cable.nu/teatime/index.rbx"
11 SRC_URI="mirror://debian/pool/main/t/${PN}/${PN}_${PV}.orig.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~x86"
16 IUSE=""
17
18 DEPEND="
19         dev-libs/glib:2
20         x11-libs/gtk+:2
21         || ( media-plugins/gst-plugins-gconf
22              media-libs/gstreamer )
23         gnome-base/gnome-vfs:2
24         gnome-base/gnome-panel
25         dev-libs/libxml2"
26 RDEPEND=${DEPEND}
27
28 S=${WORKDIR}/${PN}_applet_2-${PV}
29
30 src_prepare() {
31         epatch \
32                 "${FILESDIR}"/teatime-2.8.0-adding-slash-for-pixmaps-dir.patch \
33                 "${FILESDIR}"/03_libexec.patch \
34                 "${FILESDIR}"/04_intltool.patch \
35                 "${FILESDIR}"/70_cs.patch \
36                 "${FILESDIR}"/80_implicit.patch \
37                 "${FILESDIR}"/81_implicit_vfs.patch \
38                 "${FILESDIR}"/90_gst.patch \
39                 "${FILESDIR}"/91_gst_enable_playing.patch
40         gnome2_omf_fix
41 }