]> Pileus Git - ~andy/sunrise/blob - gnome-extra/nautilus-dropbox/nautilus-dropbox-0.6.7.ebuild
gnome-extra/nautilus-dropbox: Updated ebuild for bug 237433
[~andy/sunrise] / gnome-extra / nautilus-dropbox / nautilus-dropbox-0.6.7.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6 inherit eutils linux-info gnome2
7
8 DESCRIPTION="Store, Sync and Share Files Online"
9 HOMEPAGE="http://www.dropbox.com/"
10 SRC_URI="http://www.dropbox.com/download?dl=packages/${P}.tar.bz2"
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="debug"
15
16 RDEPEND="gnome-base/nautilus
17         dev-libs/glib:2
18         dev-python/pygtk
19         net-misc/wget
20         x11-libs/gtk+:2
21         x11-libs/libnotify
22         x11-libs/libXinerama"
23
24 DEPEND="${RDEPEND}
25         dev-util/pkgconfig
26         dev-python/docutils"
27
28 DOCS="AUTHORS ChangeLog NEWS README"
29 G2CONF="${G2CONF} $(use_enable debug) --disable-static"
30
31 CONFIG_CHECK="INOTIFY_USER"
32
33 pkg_setup () {
34         check_extra_config
35         enewgroup dropbox
36 }
37
38 src_install () {
39         gnome2_src_install
40
41         local extensiondir="$(pkg-config --variable=extensiondir libnautilus-extension)"
42         [ -z ${extensiondir} ] && die "pkg-config unable to get nautilus extensions dir"
43
44         find "${D}" -name '*.la' -exec rm -f {} + || die
45
46         fowners root:dropbox "${extensiondir}"/libnautilus-dropbox.so
47         fperms o-rwx "${extensiondir}"/libnautilus-dropbox.so
48 }
49
50 pkg_postinst () {
51         gnome2_pkg_postinst
52
53         elog "Add any users who wish to have access to the dropbox nautilus"
54         elog "plugin to the group 'dropbox'."
55         elog
56         elog "If you've installed old version, Remove \${HOME}/.dropbox-dist first."
57         elog
58         elog " $ rm -rf \${HOME}/.dropbox-dist"
59         elog " $ dropbox start -i"
60 }