]> Pileus Git - ~andy/sunrise/blob - gnome-extra/nautilus-dropbox/nautilus-dropbox-0.6.1.ebuild
90ee927d2708434e6cb34d31e9fbfa8fb0f8c631
[~andy/sunrise] / gnome-extra / nautilus-dropbox / nautilus-dropbox-0.6.1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils gnome2
6
7 DESCRIPTION="Store, Sync and Share Files Online"
8 HOMEPAGE="http://www.getdropbox.com/"
9 SRC_URI="http://www.getdropbox.com/download?dl=packages/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 RDEPEND="gnome-base/nautilus
17         dev-python/pygtk
18         dev-python/docutils
19         net-misc/wget
20         x11-libs/libnotify"
21
22 DEPEND="${RDEPEND}
23         dev-util/pkgconfig"
24
25 DOCS="AUTHORS ChangeLog NEWS README"
26
27 pkg_setup () {
28         # create the group for the daemon, if necessary
29         # truthfully this should be run for any dropbox plugin
30         enewgroup dropbox
31 }
32
33 src_install () {
34         gnome2_src_install
35
36         # Allow only for users in the dropbox group
37         # see http://forums.getdropbox.com/topic.php?id=3329&replies=5#post-22898
38         local extensiondir="$(pkg-config --variable=extensiondir libnautilus-extension)"
39         [ -z ${extensiondir} ] && die "pkg-config unable to get nautilus extensions dir"
40         fowners root:dropbox "${extensiondir}"/libnautilus-dropbox.{a,la,so} || die "fowners failed"
41         fperms o-rwx "${extensiondir}"/libnautilus-dropbox.{a,la,so} || die "fperms failed"
42 }
43
44 pkg_postinst () {
45         gnome2_pkg_postinst
46
47         elog "Add any users who wish to have access to the dropbox nautilus"
48         elog "plugin to the group 'dropbox'."
49         elog
50         elog "If you've installed old version, Remove \${HOME}/.dropbox-dist first."
51         elog
52         elog " $ rm -rf \${HOME}/.dropbox-dist"
53         elog " $ dropbox start -i"
54 }