]> Pileus Git - ~andy/sunrise/blob - gnome-extra/nautilus-dropbox/nautilus-dropbox-0.6.1.ebuild
279a0846869ca45263323521fb6140dc070918cc
[~andy/sunrise] / gnome-extra / nautilus-dropbox / nautilus-dropbox-0.6.1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils linux-info gnome2
8
9 DESCRIPTION="Store, Sync and Share Files Online"
10 HOMEPAGE="http://www.getdropbox.com/"
11 SRC_URI="http://www.getdropbox.com/download?dl=packages/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND="gnome-base/nautilus
19         dev-python/pygtk
20         dev-python/docutils
21         net-misc/wget
22         x11-libs/libnotify
23         x11-libs/libXinerama"
24
25 DEPEND="${RDEPEND}
26         dev-util/pkgconfig"
27
28 DOCS="AUTHORS ChangeLog NEWS README"
29
30 CONFIG_CHECK="INOTIFY_USER"
31
32 pkg_setup () {
33         linux-info_pkg_setup
34
35         # create the group for the daemon, if necessary
36         # truthfully this should be run for any dropbox plugin
37         enewgroup dropbox
38 }
39
40 pkg_postinst () {
41         gnome2_pkg_postinst
42
43         # Allow only for users in the dropbox group
44         # see http://forums.getdropbox.com/topic.php?id=3329&replies=5#post-22898
45         local extensiondir="$(pkg-config --variable=extensiondir libnautilus-extension)"
46         [ -z ${extensiondir} ] && die "pkg-config unable to get nautilus extensions dir"
47         chown root:dropbox "${ROOT}${extensiondir}"/libnautilus-dropbox.{a,la,so} || die "fowners failed"
48         chmod o-rwx "${ROOT}${extensiondir}"/libnautilus-dropbox.{a,la,so} || die "fperms failed"
49
50         elog "Add any users who wish to have access to the dropbox nautilus"
51         elog "plugin to the group 'dropbox'."
52         elog
53         elog "If you've installed old version, Remove \${HOME}/.dropbox-dist first."
54         elog
55         elog " $ rm -rf \${HOME}/.dropbox-dist"
56         elog " $ dropbox start -i"
57 }