]> Pileus Git - ~andy/sunrise/blob - gnome-extra/eiciel/eiciel-0.9.8.1.ebuild
gnome-extra/paperbox: Drop gnome-extra/paperbox "Doesn't build with recent tracker...
[~andy/sunrise] / gnome-extra / eiciel / eiciel-0.9.8.1.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 GCONF_DEBUG="no"
8 SCROLLKEEPER_UPDATE="no"
9
10 inherit gnome2
11
12 DESCRIPTION="ACL editor for GNOME, with Nautilus extension"
13 HOMEPAGE="http://rofi.roger-ferrer.org/eiciel/"
14 SRC_URI="http://rofi.roger-ferrer.org/eiciel/download/${P}.tar.bz2"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="nls xattr"
20
21 # revisit gtkmm, libgnome, nautilus rdepends after nautilus-3 is in portage
22 RDEPEND=">=sys-apps/acl-2.2.32
23         dev-cpp/gtkmm:2.4
24         >=gnome-base/libgnome-2.10
25         =gnome-base/nautilus-2*
26         nls? ( virtual/libintl )"
27 DEPEND="${RDEPEND}
28         dev-util/pkgconfig
29         nls? ( >=sys-devel/gettext-0.15 )"
30
31 pkg_setup() {
32         G2CONF="${G2CONF} --disable-static
33                 $(use_enable xattr user-attributes)
34                 $(use_enable nls)
35                 --with-gnome-version=2" # revisit after nautilus-3 is in portage
36         DOCS="AUTHORS README"
37         # nautilus plugins don't need .la files
38         GNOME2_LA_PUNT="yes"
39 }