]> Pileus Git - ~andy/sunrise/blob - gnome-extra/eiciel/eiciel-0.9.6.1.ebuild
gnome-extra/nautilus-dropbox: New Ebuild for bug 237433
[~andy/sunrise] / gnome-extra / eiciel / eiciel-0.9.6.1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="ACL editor for GNOME, with Nautilus extension"
6 HOMEPAGE="http://rofi.roger-ferrer.org/eiciel/"
7 SRC_URI="http://rofi.roger-ferrer.org/eiciel/download/${P}.tar.bz2"
8
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS="~amd64 ~x86"
12 IUSE="nls xattr"
13
14 RDEPEND=">=sys-apps/acl-2.2.32
15         >=dev-cpp/gtkmm-2.8.1
16         >=gnome-base/libgnome-2.10
17         >=gnome-base/libgnomeui-2.10
18         >=gnome-base/gnome-vfs-2.10
19         >=gnome-base/nautilus-2.12.2
20         nls? ( virtual/libintl )"
21 DEPEND="${RDEPEND}
22         dev-util/pkgconfig
23         nls? ( >=sys-devel/gettext-0.15 )"
24
25 src_compile() {
26         econf \
27                 $(use_enable xattr user-attributes) \
28                 $(use_enable nls) \
29                 || die "econf failed"
30
31         emake || die "emake failed"
32 }
33
34 src_install() {
35         emake DESTDIR="${D}" install || die "emake install failed"
36         dodoc AUTHORS ChangeLog README
37 }