]> Pileus Git - ~andy/sunrise/blob - gnome-extra/desktop-data-model/desktop-data-model-1.2.4.ebuild
app-admin/noobjuice-viewer: Fix qt deps, EAPI bump
[~andy/sunrise] / gnome-extra / desktop-data-model / desktop-data-model-1.2.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6 GCONF_DEBUG="no"
7 SCROLLKEEPER_UPDATE="no"
8
9 inherit gnome2
10
11 DESCRIPTION="Engine providing live updates of online data to the desktop"
12 # no real homepage yet
13 HOMEPAGE="http://ftp.gnome.org/pub/GNOME/sources/desktop-data-model/"
14
15 LICENSE="LGPL-2.1"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="+sqlite"
19
20 RDEPEND=">=dev-libs/dbus-glib-0.6
21         dev-libs/glib:2
22         >=dev-libs/libpcre-6.3
23         gnome-base/gnome-desktop:2
24         gnome-base/gnome-vfs:2
25         >=net-libs/loudmouth-1.2.2
26         >=sys-apps/dbus-1
27         x11-libs/gtk+:2
28         x11-libs/libXScrnSaver
29         sqlite? ( dev-db/sqlite:3 )"
30
31 DEPEND="virtual/pkgconfig
32         gnome-base/gconf:2
33         ${RDEPEND}"
34
35 pkg_setup() {
36         G2CONF="$(use_with sqlite)"
37 }