]> Pileus Git - ~andy/sunrise/blob - games-util/zennode/zennode-1.2.1.ebuild
x11-plugins/pidgin-sendscreenshot: Properly fix qt deps
[~andy/sunrise] / games-util / zennode / zennode-1.2.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit games
6
7 DESCRIPTION="A nodebuilder and REJECT builder for DooM engine games"
8 HOMEPAGE="http://www.mrousseau.org/programs/ZenNode/"
9 SRC_URI="http://www.mrousseau.org/programs/ZenNode/archives/${P}.zip"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 DEPEND="app-arch/unzip"
17 RDEPEND=""
18
19 S=${WORKDIR}/ZenNode-${PV}/src/ZenNode
20
21 src_unpack() {
22         unpack ${A}
23         cd ZenNode-${PV}
24         unpack ./zennode-src.zip
25 }
26
27 src_compile() {
28         emake || die "emake failed"
29 }
30
31 src_install() {
32         dogamesbin ZenNode bspdiff bspinfo compare
33         cd ../../doc
34         dohtml Custom.html History.html Overview.html README.html RMB.html \
35                 bspdiff.html bspinfo.html compare.html index.html main.css manual.html
36         prepgamesdirs
37 }