]> Pileus Git - ~andy/sunrise/blob - games-util/gamecheater/gamecheater-0.4.ebuild
dev-db/dabo: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / games-util / gamecheater / gamecheater-0.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6
7 inherit games
8
9 DESCRIPTION="a game cheater for GNU/Linux that uses ptrace system call to edit processes' memory"
10 HOMEPAGE="http://gamecheater.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE=""
17
18 DEPEND="gnome-base/libglade
19         dev-libs/glib:2
20         x11-libs/gtk+:2"
21 RDEPEND="${DEPEND}"
22
23 src_install() {
24         emake DESTDIR="${D}" install || die "install failed"
25         dodoc ChangeLog README || die "dodoc failed"
26         make_desktop_entry "${PN}" "Game Cheater" "${GAMES_DATADIR}/${PN}/pixmaps/${PN}.png"
27         prepgamesdirs
28 }